PHP Version in WordPress sicher umstellen

PHP Version in WordPress sicher umstellen

October 6, 2019 4 By Bernardo Ryan


Hallo hier ist Maja vom WordPress1x1 und in diesem Tutorial geht es darum wie ihr eure webseite auf die
neueste php version umstellen könnt bevor jetzt updated müsst ihr natürlich
prüfen ob alle schönen kompatibel ist und das könnt ihr überprüfen mit einem
weiteren plugin das ist der php compatibility jagger dazu gehe ich jetzt
auch plugins installieren und das ist diese hier mit dem schönen empfangen das
symbol von php und installiert das ganze jetzt und aktiviere und damit kann ich
jetzt überprüfen ob die installierten themes und plugins kompatibel sind mit
einer pc version die ich mir wähle das heißt ich gehe er dazu auf werkzeuge und
dann php compatibility und wäre jetzt einfach mal die höchste provision aus
und sage ich mich dann bitte alle plugins und scannen und sage scans st
das dauert jetzt ein bisschen das was ich jetzt durchlaufen ist es tatsächlich
nur das heißt es macht jetzt keine änderung oder sie müsste jetzt keine
angst haben dass er jetzt irgendwas schon umgestellt wird oder so es wird
einfach nur getestet und es gibt ein paar dinge die man beachten sollte und
zwar sehr test nicht zu 100 prozent zuverlässig sondern kann natürlich nur
die dinge testen die momentan auch verwendet werde steht auch hier dass
dieses tool nur keinen an used cars also bestimmt akt der nicht an so verwendet
wird kann es nicht testen dass es tatsächlich nur den kopf er verwendet
wird und gar nicht mehr gibt es falsche meldungen es wird manchmal erinnern
gezeigt dass eigentlich kompatibel ist das könnt ihr dann aber auch hier unten
sehen und zwar in der gibb repro das könnt ihr einfach mal einem neuen tab
öffnen und euch anschauen wie seht ihr auch dass einige plugins bereits
getestet wurde und hier wird auch gesagt mit welcher version sie kompatibel sind
so das ganze ist nun durchgelaufen und ihr seht es gibt hier insgesamt drei
labels zum einen kompatibel das heißt wir nicht das sehe das kompatibel ist
gibt es kein problem ein warning ist etwas wie naja da sollte man mal gucken
es könnte ein problem darstellen ist aber eigentlich nicht so mega dramatisch
ein ergo hingegen ist wirklich ein problem das heißt das zeigt er eine
wirkliche inkompatibilität an und einen anderen ist na ja wir können es
einfach nicht wissen und man hat dazu meistens auch noch beatles das heißt man
kann sich das auch anschauen jetzt hat man hier immer ich jetzt ja
php funktion und warning das wird jetzt wenn man eher einsteiger
oder nicht entwickler ist die nicht wahnsinnig viel sagen da kann man jetzt
gucken ob in dem in einem gitter pripro was sie unten verlinkt ist ein plug-in
was hier als andauern oder auch als er angezeigt wird weit listet ist das
bedeutet wo sie einfach sagen da gibt es kein problem mit
also ich bin es mit der relativ hohen version also 7.2 dass jetzt die höchste
version dass das normal dass nicht alles kompatibel ist das heißt wenn ich jetzt
in der höchsten version jetzt hier heraus bekomme und votings kann ich dass
solche mit einer vision oder runter noch mal probieren und noch mal die seite
kennen so ich habe das ganze jetzt nochmal mit der pp 7.0 durchlaufen
lassen da wollen wir jetzt alle plugins und ziemlich installiert habe als
kompatibel angezeigt mit der ausnahme von einem warning dieses eine wohnung
für dich jetzt aber einfach mal ignorieren weil es einfach kein elfer
ist also das ist ja ein kleiner hinweis sozusagen so bevor ich nun umstellen was
ich auf dem server mache und nicht in meine installation selber würde ich vor
allem ein backup machen das ist also ich persönlich mache das
mit applus und da gibt es auch ein video schon zu wie man backups einrichtet dann
würde ich jetzt einen backup noch mal durchlaufen lassen und vor allem wenn
ihr auf nummer sicher gehen wollt wenn ihr auf eurer live seite update bevor
ihr das macht könnt ihr auf einen lokalen installation das ganze testen
ich würde euch das empfehlen fallen wenn es eine wichtige webseite ist die
vielleicht auch viele besucher hat bevor ihr eure webseite quasi kaputt machte in
dem ihr eine falsche php oder eine pc version installiert den nicht kompatibel
ist würde ich das an eurer stelle immer vorher testen auf einem lokalen server
dazu müsst ihr über memc zum beispiel ein lokalen server einrichten eurer
webseite umziehen dort kann man auch eine pc-version einstellen ich zeige
euch das mal eben also an ihr habt jetzt schon map installiert da könnt ihr hier
auf einstellungen php und könnte jetzt hier auch die php version auswählen und
einstellen die einstellung die hier macht die wären
dann für alle lokalen installationen die auf diesem lokalen server habt wenn du
das jetzt getestet habt könnt ihr das auch direkt bei eurem server machen
solange ihr vorher noch ein backup gemacht habt und wichtig ist dabei
dass ihr sicherstellt dass wenn ihr eine pc-version einstellt dass hier im
zweifel wieder zurückstellen könnt also dass sie wieder auf eine andere
niedrigere version umstellen könnte so solche bei all inkl könnt ihr umstellen
in dem ihr euch in das gas in den knast bereich einloggt jetzt habe ich jetzt
schon getan dann bin ich oft domains gegangen ihr
könnt auch falls sich unterschiedliche accounts auf accounts gehen und dann den
einzelnen account auswählen euch der einwanderung dann auf domains aber da wo
eure domains da drin sind könnt ihr hier die psp-version einstellen und auch
sehen in einem fall habe ich jetzt schon alle auf 7.0 gestellt ich zeige euch mal
wie das gehen würde wenn ihr das umstellt in meinem fall ist das jetzt
hier keine domain sollen ich muss tatsächlich in den account gehen dazu
gehe ich jetzt mal auf kargem ich hier ein in ein wehr in den unterarm
sozusagen gehe auf domainer php version 7.0 drin hätte ich jetzt hier eine
niedrigere version würde ich hier auch bearbeiten gehen und jetzt hier eine
andere version auswählen wichtig unbedingt mindestens 5.6 auswählen oder
7.0 und höhe ist wenn ihr das gemacht habe dann klicke hier auf speichern
das kann jetzt mein favorit nichts geändert
aber jetzt das kann halt einige minuten auch dauernd auch mal zehn und zwanzig
minuten so lange würde ich warten und das dann hier im auge behalten und
einfach aktualisieren und gucken dass das dass hier noch alles läuft genau
wenn ihr das umgestellt hat einfach im auge behalten wenn nach einer halben
stunde alles noch so läuft wie es soll dann habt ihr erfolgreich umgestellt und
könnt euch freuen dass ihr auf der aktuellsten version läuft alles klar
dann wünsche ich euch viel erfolg damit wurde nerven vor allem aber ist auch
kein hexenwerk wie ihr seht und im zweifel könnte tier hier immer noch
zurück stellenweise dann etwas den support zu nachfragen es wird im prinzip
ähnlich teuren dateien und nichts an der datenbank geändert deswegen ist das
klingt das erst mal sehr aufregend aber so richtig schlimm ist das jetzt nicht
sollte jetzt was schief gehen dann könnte man immer noch auf niedrigere
version wird zurückstellen deine vier voller witz und bis zum nächsten
tutorial